We reported at the beginning of the month that the openSUSE Tumbleweed developers are preparing a massive package rebuild to make the GCC (GNU Compiler Collection) 6 the default compiler for the rolling operating system.

Migrating to a new default compiler is the hardest task for a Linux kernel-based operating system, as almost all the pre-installed packages need to be rebuilt using the new compiler, and package maintainers have a hard time during this transition.

And it looks like openSUSE Tumbleweed developers have run into some trouble today, May 23, 2016, as Dominique Leuenberger asked the community to help test the packages that fail to build with GCC 6, or that need special attention.

“Dear openSUSE Hackers, as you’re doubtless aware, we’re trying to move to GCC 6 as our default compiler,” said Dominique Leuenberger in today’s announcement. “For this to work, your help is needed in order to make this happen.”

Mozilla Firefox and Mozilla Thunderbird fail to build with GCC 6

The packages that failed to build with GCC 6 have been split into two categories, Ring 0/1 and Ring 2, which those who want to help the openSUSE devs fix them, can access at https://goo.gl/BMKxK0 and https://goo.gl/LkHaUM.

While the first category includes only a few important software (Xen, GDB, or Mozilla’s NSS), the second one list a total of 40 packages, among which the popular Mozilla Firefox web browser and Mozilla Thunderbird email and news client.

So, if you want to help, make sure that you check the replies from other openSUSE hackers first on the opensuse-factory mailing list, and, if a package doesn’t have a fix, you can attempt to submit one.

openSUSE Tumbleweed is one of the most popular rolling operating systems these days, as it always receives the latest software packages and GNU/Linux technologies, so keep an eye on it!

Let’s block ads! (Why?)

Related Posts

Facebook Comments

Return to Top ▲Return to Top ▲