The NetBSD team announced the general availability of the first point release of the NetBSD 7.0 operating system, adding assorted bug fixes and security updates to its core components.

NetBSD 7.0.1 comes seven months after the release of NetBSD 7.0, during which the skilled developers behind the BSD-based operating system managed to update most of the packages to their latest versions available at the moment of writing this article, thus patching some critical security vulnerabilities.

According to the release notes, NetBSD 7.0.1 fixes multiple vulnerabilities in the compatibility layers and the NTP (Network Time Protocol) daemon, which has now been updated to version 4.2.8p7, and addresses a potential remote code execution in the CGI handlers of the bozohttpd web server, updated by now to version 20160415.

Other major components updated in this first point release of NetBSD 7.0 are BIND 9.10.3-P4, OpenSSH 7.2, OpenSSL 1.0.1t, expat 2.1.0, tzdata 2016b, and Xen 4.4, representing a selected subset of fixes that have been considered important for various security reasons, and to improve the overall stability of the operating system.

ODROID-C1 support has been improved

The entire changelog of the NetBSD 7.0.1 release has been attached below. By taking a quick look at it, you can notice that numerous crashes have been patched, and there’s now better support for the ODROID-C1 single-board computer, as well as for the x86 and SPARC64 instruction set architectures, and the NFS file system.

Talking about ODROID-C1, NetBSD 7.0 introduced support for numerous new ARM SBCs, such as Raspberry Pi 2, BeagleBone, BeagleBone Black, Banana Pi, MiraBox, BeagleBoard, Cubietruck, Cubieboard2, Netwalker, ZedBoard, Parallella, and Kobo Touch. NetBSD 7.0.1 is a recommended update for all those are using NetBSD 7.0.

You can update your NetBSD 7.0 installation to version 7.0.1 using the built-in package manager, as all the fixes mentioned above are now live in the main software repositories of the operating system, but newcomers will need to download the NetBSD 7.0.1 install mediums right now via our website.

Let’s block ads! (Why?)

Related Posts

Facebook Comments

Return to Top ▲Return to Top ▲