Earlier, after releasing Linux kernel 4.6.2, Linux kernel 4.4.13 LTS, and Linux kernel 3.14.72 LTS into the wild, renowned kernel developer Greg Kroah-Hartman announced the general availability of Linux kernel 4.5.7.

However, this is not your usual announcement for a new maintenance update to the Linux 4.5 kernel series, but an end of life one. Yes, you are reading it right, Linux kernel 4.5.7 is the last in the series, and Greg Kroah-Hartman urges everyone still using a kernel from the Linux 4.5 branch to move to the most recent version.

“I’m announcing the release of the 4.5.7 kernel. All users of the 4.5 kernel series must upgrade. This is the LAST 4.5.y stable kernel release. It is now end-of-life, please move to the 4.6.y kernel tree now as this tree will not be getting any more updates,” said Greg Kroah-Hartman in the announcement.

There are many GNU/Linux distributions out there powered by kernel packages from the Linux 4.5 series, and they now have two alternatives, to either upgrade as quick as possible to version 4.5.7 or start migrating to the Linux 4.6 branch. Linux kernel 4.6.2 has also been released a few hours ago so that you can upgrade now.

What’s new in Linux kernel 4.5.7

If you don’t want to move to a kernel from the Linux 4.6 series just yet, we’re informing you today that Linux kernel 4.5.7 packs numerous improvements to the Btrfs file system, multiple enhancements to the MIPS and ARM hardware architectures, as well as other core kernel and minor bug fixes.

There are, of course, the usual driver updates, this time for things like GPU (mostly AMDGPU, Intel i915, and GMA500), CPUIdle, CLK, Video4Linux, PCI, PINCTRL, MFD, SCSI, Xen, and networking (numerous Atheros and Realtek wireless drivers). In numbers, Linux kernel 4.5.7 changes a total of 126, with 926 insertions and 438 deletions.

The Linux kernel 4.5.7 sources are available for download right now via our website or directly from kernel.org, but if you are maintaining a GNU/Linux operating system powered by a kernel from the Linux 4.5 branch, please try to keep in mind that it will no longer be maintained. Move to the Linux 4.6 series as soon as possible!

Let’s block ads! (Why?)

Related Posts

Facebook Comments

Return to Top ▲Return to Top ▲