Apple is now blocking older versions of Adobe’s Flash Player because of security vulnerabilities that were patched in the most recent release, prompting users to update as soon as possible to continue using the plug-in in Safari.

Flash Player has become one of the most insecure parts of the web, and although it’s still in use right now, the percentage of websites and tech companies supporting is falling dramatically as everyone searches for safer browsing.

Apple announced in a June 20 advisory that it was disabling old versions of Adobe Flash Player in Safari because of the security vulnerabilities that could expose users to online attacks. Adobe launched Flash Player 22.0.0.192 last week to fix flaws in the application, after it discovered active exploits launched against targets in countries such as Russia, South Korea, China, India, and others.

As a result, Safari users need to update to this latest version in order to continue loading Flash content in the browser, otherwise, they’ll see the notification pictured in this article.

“Adobe Flash Player is out-of-date. The version of this plug-in on your computer does not include the latest security updates and is blocked. To continue using Adobe Flash Player, download an update from Adobe,” the notification reads, giving users an option to quickly download the latest Flash version from Adobe.

Flash also blocked by default on the desktop

This isn’t the only move that Apple is making to protect users against Flash Player vulnerabilities. In the new macOS version that’s already available as a developer preview, Safari 10 automatically disables Flash Player and instead tries to load the HTML5 version of each website, should one be available.

Flash content is clearly marked on its webpage, and users are allowed to manually load it should they find it absolutely mandatory.

“Whenever a user enables a plug-in on a website, it’ll remain enabled as long as the user regularly visits the website and website still uses the plug-in. More specifically, Safari expires a user’s request to activate a plug-in on a particular website after it hasn’t seen that plug-in used on that site for a little over a month,” Apple explains how the new system works.

The change will take place when the new version of its desktop operating system rolls out, which, according to sources, should happen later this year.

Let’s block ads! (Why?)

Related Posts

Facebook Comments

Return to Top ▲Return to Top ▲